Announcement

Collapse
No announcement yet.

Action keyframe for loop skipping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Action keyframe for loop skipping

    I'm having a problem where it seems that the playhead skips over the action keyframe in my scenes and stops at the end of the director. It's for a simple loop in a TL scene, the command is:

    THIS_SCENE*STAGE*DIRECTOR*BULLET SHOW F20;
    THIS_SCENE*STAGE*DIRECTOR*BULLET CONTINUE ANIMATION;

    It works inconsistently or not at all. There are several different looping scenes on the same toggle. I'm wondering if anyone has experienced this and if so were you able to discover the cause?

    Thanks!


  • #2
    I'm not sure i think "THIS_SCENE*STAGE*DIRECTOR*BULLET CONTINUE ANIMATION;" animation is unnecessary.

    "THIS_SCENE*STAGE*DIRECTOR*BULLET CONTINUE;" Can you try this one?
    Last edited by meret; 05-04-2021, 05:27 PM.

    Comment


    • #3
      Thanks for your response. I've tried both CONTINUE and CONTINUE ANIMATION. I will stick with CONTINUE and monitor the results.

      Comment


      • #4
        This will work:
        THIS_SCENE*STAGE*DIRECTOR*BULLET CONTINUE_AT F20;
        If you have a named tag at F20 called e.g. A and a named tag at the last frame (looppoint) named e.g. B, you can write:
        THIS_SCENE*STAGE*DIRECTOR*$BULLET GOTO_TRIO $A $B
        Last edited by Lars Henriksen; 05-05-2021, 10:31 AM.

        Comment


        • #5
          Originally Posted by dwFisher View Post
          I'm having a problem where it seems that the playhead skips over the action keyframe in my scenes and stops at the end of the director. It's for a simple loop in a TL scene, the command is:

          THIS_SCENE*STAGE*DIRECTOR*BULLET SHOW F20;
          THIS_SCENE*STAGE*DIRECTOR*BULLET CONTINUE ANIMATION;

          It works inconsistently or not at all. There are several different looping scenes on the same toggle. I'm wondering if anyone has experienced this and if so were you able to discover the cause?

          Thanks!
          I've sometimes had the problem of action keyframes not been triggered when they're not on Stop point. Have you tried putting a Tag right on the action keyframe in the time line? A Tag won't stop or pause the animation but seems to make sure the action is triggered.

          Comment

          Working...
          X