Announcement

Collapse
No announcement yet.

Question about labels, Viz One

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Shotski2
    replied
    The OnPreview did work where it just showed the label in Trio only and not on output. I will take that for now.

    Leave a comment:


  • Novacane89
    replied
    Hi Shotski,

    Couple of options come to mind:

    1-Check against dongle lic number or hostname if preview and output is seperate viz engines

    If your preview engine is a different engine from your output engine you could use Viz Script to check the dongle lic number...
    .
    Do a command to get the viz engine license dongle number OR hostname then use it in this code:

    "If dongleNumber/Hostname = "42356G3452ER345234/PCHOSTNAME" then
    clipNameFontContainer.Active = true
    else
    clipNameFontContainer.Active = false
    end if
    "
    Something like that.

    -----

    2-IF PREVIEW and PROGRAM is on the same machine...

    I was going to suggest to do a check on the port number . So if the port number is 6100 it is preview and text should be active, else if the port is 6800 the text should be inactive since it is output... However I checked the viz script doc and did not see a call to GET port number of current engine BUT you could use
    System.SendCommand("1 MAIN*CONFIGURATION*COMMUNICATION*SERVICE GET")
    This command^ returns the port number of the current engine as string.

    ----

    3- I know there is a OnPreview(active as integer) event in Viz Script that would seem to be perfect for this kind of thing but I haven't tested it as of late.

    Best Regards
    Graham
    Last edited by Novacane89; 01-06-2020, 01:33 AM.

    Leave a comment:


  • Shotski2
    started a topic Question about labels, Viz One

    Question about labels, Viz One

    Hello All,

    We have clips that we play from Viz One and directors want a way to identify the clip since they all start in black. I can get the clip name from Viz One via scripting but it shows over the clip on playout. I want the label to only show in preview and not on air as the clip plays. I have tried different keying methods but have not found a solution.

    Any help is greatly appreciated.

Working...
X